Jan

12 posts

Jan

Jan

@Jan10com

big feet and infosec ftw

Norway Katılım Nisan 2009
205 Takip Edilen34 Takipçiler
Jan
Jan@Jan10com·
Sentinel analytics rules have _SentinelHealth() for failure monitoring. Defender XDR custom detections have... nothing. No table, no native alerting. Just the GUI. How is everyone catching these silent detection failures? @msftsecurity #MicrosoftDefender
English
1
0
0
38
Jan
Jan@Jan10com·
Yo, fam! Why’s Action Center history not popping up in my Advanced Hunting tables? Spill the tea, #MicrosoftDefender!
English
0
0
1
43
Jan
Jan@Jan10com·
@ellishlomo Why is this posted in LinkedIn though? Shouldn't this be in the Sentinel blog or learn something something Sentinel?
English
0
0
2
20
Jan
Jan@Jan10com·
@reprise_99 Find the first and last timestamp | summarize min(timestamp), max(timestamp)
English
0
1
3
212
Matt Zorich
Matt Zorich@reprise_99·
People often share full Kusto queries, which is awesome, but what about those handy one liners and tips you have picked up along the way? Here are some of my favourites, share yours below! Extend an additional column for your local time, example +5 UTC: | extend LocalTime = TimeGenerated +5h Find events only on weekends, cast a variable to make it easy to read: let Saturday = time(6.00:00:00); let Sunday = time(0.00:00:00); AuditLogs | where dayofweek(TimeGenerated) in (Saturday, Sunday) Find events during certain hours of the day: | where hourofday(TimeGenerated) !between (4 .. 23) Calculate the minutes (or hours or days etc) between two events: | extend ['Minutes Between Events']=datetime_diff("minute",Timestamp1,Timestamp2) Parse the details, including browser family and version etc of a user agent: | extend UserAgentDetail = todynamic(parse_user_agent(UserAgent, "browser")) Decode base64 encoded strings, useful for PowerShell: | extend DecodedCommand = base64_decode_tostring(EncodedCommand) Rename columns while using project: | project LogTime=TimeGenerated, SigninLocation=Location, IP=IPAddress, Agent=UserAgent
English
6
39
216
14K
Jan
Jan@Jan10com·
In #MicrosoftDefender how do you see when an incident was created? 🤔
English
0
0
0
59
Jan
Jan@Jan10com·
@ITguySoCal You might check AuditLogs as well 🫠
English
1
0
1
357
Joe Stocker
Joe Stocker@ITguySoCal·
KQL to spot missing Microsoft logs (excludes weekends since those are normally low) SigninLogs | where TimeGenerated >= ago(90d) | summarize SignInCount = count() by bin(datetime_utc_to_local(TimeGenerated,"US/Pacific"), 1d) | where dayofweek(Column1) !="6.00:00:00" and dayofweek(Column1) !="00:00:00" | order by Column1 I have additional variations of this that I am working on such as only plotting when the variance is > 30% - input from community is welcome.
Joe Stocker tweet media
Nathan McNulty@NathanMcNulty

17 days... It took 17 days for us to realize we were missing logs and get Microsoft to come to that conclusion and fix it 😩 Understandable though, because most of us are focused on analyzing the data we have, not noticing what is missing

English
5
65
310
49.2K
Jan
Jan@Jan10com·
@BertJanCyber Why can't they just allow adx() in Analytics rules instead of introducing more complexity and cost? 🤷‍♂️
English
0
0
0
19
Jan
Jan@Jan10com·
Sentinel Analytics: Why can't I add UserPrincipalName to Account type directly? UserPrincipalName used by Defender, but Sentinel makes it so difficult. Is splitting the preferred solution? #MicrosoftSentinel #L60" target="_blank" rel="nofollow noopener">github.com/Azure/Azure-Se…
English
0
0
1
69
Jan
Jan@Jan10com·
You can resolve alerts in Defender, but not in Sentinel🤔 #MicrosoftSentinel
English
0
0
1
43
Jan
Jan@Jan10com·
@reprise_99 Hi Matt, how do query for phishing emails with QR code inside? 🤠
English
2
0
2
32.7K
Matt Zorich
Matt Zorich@reprise_99·
Kusto tip, if you are looking for recon in your environment and also use Defender for Identity, you can exclude the DfI sensor, as it uses various ports, including RDP to help map the network DeviceNetworkEvents | where InitiatingProcessFileName != "Microsoft.Tri.Sensor.exe"
English
3
10
55
6.8K