William Francillette

183 posts

William Francillette

William Francillette

@WillTheFrenchie

Luton, England Katılım Ağustos 2022
138 Takip Edilen151 Takipçiler
Ru Campbell
Ru Campbell@rucam365·
Not a dev. but like most folks in our bubble have been using AI coding agents a ton over last 3-6mo. And I need to ask people who know better than I do: For every take about not having to look at the code anymore, I see another from someone who does look at the code and sees junk. It works, but I assume at the cost of maintainability, performance, and reliability. Is it a case of constantly refining skills, instructions, and agents to achieve code that doesn’t really need human review? Do the models get so good with the laws of scaling we no longer need skills? (every AI coding improvement being Yet Another MD File doesn’t seem right) Or: Are the folks who “just use” whatever’s generated, with no code review, the right ones? Assuming it passes UAT, vulnerability scanning, CSPM, etc. Intuitively this doesn’t seem right, but if it works…? And do you just keep prompting “review the code for inefficiencies” until it taps out? Vibe coding is addictive and I wonder if that’s for the same slot-machine reason as scrolling. Sometimes it’s incredible and nails it, other times it fails miserably so you keep trying: only one more prompt, then i’m good!
Dmitriy Kovalenko@neogoose_btw

I got 2 exact same AI generated contributions and it is intimidating how much code they are generating. The one on the left is the AI generated PR code, the one on the right is the actual fix needed. The bug is SUPER easy while the agent is likely mislead by the context provided in the issue which is leading to 100x more code to fix it. My change was also AI generated, it's just the way you phrase your request. It's not a surprise Garry generates 100k LOC a week

English
4
0
16
2.5K
Nathan McNulty
Nathan McNulty@NathanMcNulty·
@WillTheFrenchie @DXPetti I'm working through trying to simplify the user experience right now for normal service principals, but we would just skip secret creation and add the federated credential, then use the passkeylogin script in the federated app side I'm working on a GitHub Action for this stuff
English
1
0
2
82
Nathan McNulty
Nathan McNulty@NathanMcNulty·
Holy crap 🤯 🎉 Success! The Key Vault-backed passkey authentication works! It took me about an hour fixing up some issues Sonnet 4.5 had with Key Vault permissions and how to use Key Vault, but it works!!! Working on some quality of life changes, will publish this soon 🥳
Nathan McNulty tweet media
English
2
6
88
17.2K
William Francillette
William Francillette@WillTheFrenchie·
@NathanMcNulty @DXPetti Thats very interesting, Thanks for sharing I can't wait for you guys to crack the federated credentials so that we can build multi tenant apps and provide comprehensive reports for multi app tenants There so much that is not exposed publicly.
English
1
0
1
94
Nathan McNulty
Nathan McNulty@NathanMcNulty·
@DXPetti There are many things Service Principals can't touch, either due to no applicaiton permissions available or no legitimate way to obtain a token for the API This allows us to use a service account with a key vault backed passkey to securely authenticate to touch these systems :)
English
1
2
17
350
William Francillette retweetledi
Ru Campbell
Ru Campbell@rucam365·
Speaking at #HIPConf in Frankfurt on 10 February. We've built a Microsoft 365 security posture management app and service, and one thing that's become clear a small set of controls deliver disproportionate results at tenant hardening. This session is all about how you can get a whole lot in Entra wrong as long as you get those few things right. Register for 'Entra ID’s 80/20: Practical Lessons in High-Impact Security Controls' at: register.hipconf.com/7B9lvD
Ru Campbell tweet media
English
0
3
11
1.2K
William Francillette retweetledi
Joe Stocker
Joe Stocker@ITguySoCal·
Even though Microsoft provided a PowerShell command in April 2025 to disable the SMTP DirectSend feature in Exchange Online, we are still seeing attackers successfully reach the inbox for organizations that do not have their DMARC DNS Record set to Reject or Quarantine. According to public DNS, 30% of the Fortune 500 are vulnerable. Small to Medium orgs are even more likely to be exposed. It is recommended to perform threat hunting to identify these emails. Here is KQL we used to successfully detect DirectSend Phishing in Microsoft Defender XDR or Microsoft Sentinel (security.microsoft.com) EmailEvents |where Timestamp > ago(30d) | where EmailDirection == “Inbound” | extend LeftPartSender = substring(SenderFromAddress, 0, indexof(SenderFromAddress, “@”)) | extend LeftPartRecipient = substring(RecipientEmailAddress, 0, indexof(RecipientEmailAddress, “@”)) | where LeftPartSender == LeftPartRecipient | where isempty(Connectors) // not coming in on a connector | where DeliveryLocation == “Inbox/folder” | where parse_json(AuthenticationDetails) contains “fail” | project Timestamp, RecipientEmailAddress, SenderFromAddress, Subject, NetworkMessageId, EmailDirection, Connectors, SenderIPv4 Threat hunting on the EmailEvents table requires the Microsoft Defender for Office P2 license. Otherwise, follow the MSFT reference links below for syntax on Historical Message Trace. One of the easiest ways to detect DirectSend is when the sender and recipient are identical (which is typically unusual). We have observed cases where using an exact match of sender and recipient domain name does not detect all results. In some cases the sender domain is a MOERA domain (alias@tenant.mail.onmicrosoft.com) and they use a different alias on the same mailbox for the recipient address (such as the primary SMTP alias). We suspect this was done to evade the exact == comparison, so we updated the query above to look for the alias matching instead of domain matching (this resulted in finding additional results). If you get too many results, try adding this where clause before the last project statement to reduce results: | where Subject has_any ( 'Pay Raise', 'Strategic Organizational Restructuring', 'Bonus Disbursement', 'Bonus Distribution', 'Merit-Based Pay', 'Compensation Bonus', 'Compensation Review', 'Wage Increase', 'Wages Increase', 'Incentive') References: thecloudtechnologist.com/2025/08/09/an-… techcommunity.microsoft.com/blog/exchange/… techcommunity.microsoft.com/blog/exchange/… If you don't have a valid use of DirectSend you can disable it with this Exchange Online PowerShell cmdlet: Set-OrganizationConfig -RejectDirectSend $true
English
14
75
354
31.6K
Ru Campbell
Ru Campbell@rucam365·
More art than science.
Ru Campbell tweet media
English
17
33
356
30K
William Francillette retweetledi
Ewelina Paczkowska (Welka's World)
I’ll be delivering “Zero to Hero: Adaptive Protection with Insider Risk Management and Conditional Access” at 8:15 AM (GMT) on February 21st, 2025, during the Workplace Ninja User Group Denmark meeting. Register now: meetup.com/wpninjasdk/eve…
Ewelina Paczkowska (Welka's World) tweet media
English
1
4
20
1.7K
William Francillette retweetledi
Merill Fernando
Merill Fernando@merill·
🌱 Did you know that we have 100+ built-in roles in Microsoft Entra? Here's a free mind map of all of them 👇 BONUS → I'm giving away a free pdf of all my Entra mind maps
Merill Fernando tweet media
English
14
81
365
41.5K
William Francillette
William Francillette@WillTheFrenchie·
To graph gurus Do you know what is the value of methodsRegistered for passkey in userRegistrationDetails/Get-MgBetaReportAuthenticationMethodUserRegistrationDetail @merill ? @DanielatOCN ? Thanks in advance!
English
4
1
1
1K
Daniel Bradley
Daniel Bradley@DanielatOCN·
@WillTheFrenchie @merill If you go to the user registration details page in Entra, you’ll be able to open developer mode (network tab) in your browser and refresh the page and see the Graph query and response in action which should show you the info. I’d check now for you but I’m stuck on the train
English
1
0
0
51
Alexander
Alexander@flabbiersteam·
@DrAzureAD I find the graph sdk cmdlets also easy to use. The hard part for people averse to programming is the authorization part and that remained the same. Nice to see some movement though.
English
1
0
1
38
JH
JH@jhaych1111·
@WillTheFrenchie not sure if you still use this can you respond so I can direct message you please? Thanks
English
1
0
0
15
William Francillette
William Francillette@WillTheFrenchie·
@merill Completely agree, even zooming on and out doesn't resolve the issue but make it worst ...
English
0
0
1
69
Merill Fernando
Merill Fernando@merill·
I spend a lot of time on Microsoft Learn docs and this really annoys me.... Does it annoy you too?
English
18
5
120
16.5K